System Requirements for PLC Technician Online Certificate Programs

Mon, 06/07/2021 - 16:39

If you’re considering taking the PLC Technician certificate program, maybe you’ve been wondering what kind of a computer you need to install our program curriculum and simulation software.

Luckily, the system requirements are modest, so most computers will meet them.

The three system requirements are:

  1. Operating system

Our program software and simulation will run only on a PC running Windows operating system. Any Windows version (Windows XP, Vista, 7, 8, 8.1 and 10) will suffice. It will NOT work on Apple computers running Mac Operating Systems such as Macbook, Chromebook computers running Chrome Operating Systems such as Google Pixelbook or any device running Linux Operating Systems.

  1. Hardware requirements:

  • Intel Pentium or equivalent (Intel i3, i5, i7 or i9 processor)
  • 512 MB RAM
  • 500 MB hard-disk space
  • Sound card
  1. Internet connection, browser and e-mail address

Our program is web-based so you will need an active internet connection to access the course curriculum part of the software. You will also be required to have an internet connection when you are ready to do your online exam. You must use Internet Explorer to take your online exam. Unfortunately, other browsers, including Google Chrome, Firefox or Microsoft Edge do not fully support ActiveX controls that our online system requires. Also, you will need an e-mail address to receive the exam results.

Check out this video where our Senior Technical Consultant, Geet, talks about the system requirements for all our technical programs.

If you still have any questions regarding this topic, or any other program-related questions, call us toll-free at 1-866-279-1457 or e-mail us at support@gbctechtraining.com. Our Support Consultants will be happy to assist you.


Originally published on Feb 14, 2020.

Add new comment